Emergency Maintenance for resolving issue on the system
Incident Report for GGNetwork
Resolved
This incident has been resolved.
Posted Jun 29, 2020 - 21:41 UTC
Update
We are continuing to investigate this issue.
Posted Jun 29, 2020 - 20:03 UTC
Investigating
We are currently investigating this issue.
Posted Jun 29, 2020 - 20:03 UTC
This incident affected: Login & Account Services, Lobby, Cash Games, and Tournaments.